atax1a suggested `map-sift` for `map-if`, to allude to `sift` (which technically would require map-sift ( seq quot: ( elt -- newelt/f ) -- newseq ) erg mentioned that the `-if` might allude to a partition, and maybe use `-when` instead. I think the `map-sift` is nicer and closely alludes to a map followed by a (modified) sift. To accommodate for variants, I propose the following two names, but `map-if*` might not be needed at all : map-sift ( ... seq quot: ( ... elt -- ... newelt ? ) -- ... newseq ) : map-sift* ( ... seq quot: ( ... elt -- ... newelt/f ) -- ... newseq )